Xenon® service interruption

Major incident Voicepoint Xenon® Voicepoint Xenon® Dragon Voicepoint Xenon® Flow Voicepoint Xenon® Fusion
2025-09-27 01:54 CEST · 7 hours, 11 minutes

Updates

Post-mortem

period
September 27, 2025, 01:54 - 09:05 (Xenon® services restored)

Affected services

  • Xenon® platform (incl. all dependent modules and services)

Impact on customers
During the disruption, our services were temporarily completely unavailable.

Cause
A faulty update within the Microsoft Azure platform in the Switzerland North region led to problems with certificates for connections in this region. This resulted in a large-scale disruption of numerous Azure services, which also affected our Xenon® platform.
[Azure Tracking ID: BT6W-FX0]

Reaction from Microsoft, September 27, 2025

  • 01:54 - Start of the disruption
  • 02:08 - Error detected by monitoring
  • 04:33 - Cause of error identified (faulty update), rollback started
  • 06:00 - Most of the services restored
  • 23:59 - Completion of all recovery activities, full availability of all Azure services confirmed

Reaction from Voicepoint

  • After completion of the initial Azure recovery, all Xenon® services were started up in a controlled manner.
  • We have comprehensively checked the functionality and stability.
  • All our services have been fully available again since September 27, 2025, 09:05.

Lessons learned & next steps

  • Testing additional redundancy options.
  • Optimization of own service recovery processes.
September 29, 2025 · 12:49 CEST
Resolved

All our Xenon® services are now fully available again. We continue to monitor the situation but currently see no further impact.

Thank you for your patience!

September 27, 2025 · 09:27 CEST
Update

The current unavailability of our services is related to an outage in the Microsoft Azure Switzerland North region. This also affects dependent services such as our Xenon platform.

We are working to restore availability as quickly as possible and will keep you informed here about further developments.

Thank you for your understanding!

September 27, 2025 · 03:17 CEST
Issue

Our services are currently unavailable due to a technical issue. We are working diligently to restore availability as quickly as possible and will keep you updated here.

Thank you for your understanding and patience!

September 27, 2025 · 03:03 CEST

← Back