Interruption

Minor incident Voicepoint Xenon® Voicepoint Xenon® Dragon Voicepoint Xenon® Flow Voicepoint Xenon® Fusion
2026-02-06 06:10 CET · 1 hour, 52 minutes

Updates

Resolved

All our Xenon® services are now fully available again. We continue to monitor the situation but currently see no further impact.

Thank you for your patience!

February 6, 2026 · 08:00 CET
Issue

Our services are currently unavailable due to a technical issue. We are working diligently to restore availability as quickly as possible and will keep you updated here.

Thank you for your understanding and patience!

February 6, 2026 · 06:10 CET

← Back