Interruption

Minor incident Voicepoint Argon® Voicepoint Argon® Device Voicepoint Argon® Identity
2026-03-28 02:20 CET · 1 hour

Updates

Resolved

The incident has been resolved and all services are operating normally again.

We apologize for any inconvenience caused and thank you for your patience.
Your Voicepoint Team

March 28, 2026 · 03:15 CET
Issue

Our services are currently unavailable due to a technical issue. We are working diligently to restore availability as quickly as possible and will keep you updated here.

Thank you for your understanding and patience!

March 28, 2026 · 02:20 CET

← Back